BlackBoard browser compatability issues

Some features in blackboard may not work correctly if you are using a browser not recommended for Blackboard 9. Some of the newer versions do not support all the features of Blackboard 9.
View list of compatible browsers
Also, for Internet Explorer 9 users, there is a compatibility mode that may work for you. Find out more about compatibility mode

This entry was posted in Uncategorized. Bookmark the permalink.

Leave a Reply